sphfreq-1.0.3 --> mehr LEDs :D

  • Moin Leutz!

    Hatte mal wieder ein wenig Zeit über - also endlich eine neue Version mit den fehlenden LEDs (soweit möglich).

    Brainfuck-Quellcode

    1. *** sphfreq v1.0.3 (c)2016 @speedUpLoop / emkay ***
    2. Setting LTE-Band / Frequency (or LED-State) of Telekom-Speedport-Hybrid
    3. Usage: sphfreq [show/watch/all/800/1800/2600/low/high]
    4. Options:
    5. show show current lte-config
    6. watch similar to 'show' - with auto-update
    7. -------------------------------------------------------------------------------
    8. all allow 800MHz, 1800MHz, 2600MHz --> hex-mask 80044
    9. 800 allow 800MHz --> hex-mask 80000
    10. 1800 allow 1800MHz --> hex-mask 4
    11. 2600 allow 2600MHz --> hex-mask 40
    12. low allow 800MHz, 1800MHz --> hex-mask 80004
    13. high allow 1800MHz, 2600MHz --> hex-mask 44
    14. --LEDs-------------------------------------------------------------------------
    15. Usage: sphfreq leds all [off/hardoff]
    16. Options:
    17. off turn all LEDs off
    18. hardoff deactivate all LEDs until reboot
    19. Usage: sphfreq leds [power/red/lteall/lte1/lte2/lte3/lte4/lte5] [on/blink/off]
    20. Usage: sphfreq leds [dsl/online/voip/dect] [on/blink/off]
    21. Usage: sphfreq leds [service1/service2/wlan] [on/off]
    22. Usage: sphfreq leds [wps] [blink/off]
    23. turn LED on or off - or let it blink...

    Der Thread zum Tool ist immer noch sphfreq - Tool zum Einstellen der LTE-Frequenz(en) :D
    Und die Beispiele bei den älteren Versionen in der WebDisk sollten immer noch prima funktionieren ;)

    Alle LEDs sind nun erreichbar, aber service1/service2 (bitte warten) und wlan blinken leider nicht -- kann man aber natürlich von Hand erreichen -- und die wps-LED kann leider nicht dauerleuchten... (Einschränkung der API, welche ich noch nicht umgehen konnte)
    -
    Denkt bitte an den Unterschied zwischen hardoff und den normalen on/off-Modi:
    hardoff gilt bis zum Reboot - alle anderen Modi, bis man selbst - oder die Firmware - den Modus ändert.

    Will man also die LEDs zur Laufzeit setzen, so sollte man das in regelmäßigen Abständen tun - sonst kann es sein, daß die Firmware LEDs wieder aktiviert/deaktiviert, deren Modus man geändert hatte...
    (wenn man zB. alle LEDs softoff geschaltet hat, sich danach aber die Signalstärke ändert - schaltet die FW evtl. die LTE-LEDs wieder ein)

    Viel Spaß damit :D

    mfg, emkay

    EDIT: ab der v04 braucht man noch --> libiconv.so aus der FW-V3 (um sphfreq-Probleme zu lösen...)
    Dateien

    63.454 mal gelesen